add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube
nehemiahawesome1

65 months ago

I had 3 viruses on my mac all relating safari and they were moved to trash. it is speedier just a little but not that much. on my hackintosh my internet is fine and fast but my macbook is like laggy even though i have 8 gb on hack but only 4 on book. what should i do. all i did was use clam X i think

Comments

  • 65 months ago
  • 1 point

Did ClamX AV identify them as known virii, and are there any search results on how to remove them? In all my years of Mac use, actually getting infected is pretty hard to do, unless you install something from a shady source & give it your Admin password in the process.

  • 65 months ago
  • 1 point

i give my admin password to every sing thing i ever downloaded. except chrome. and i don't know. i just started a scan and 3 things popped up so i sent to and emptied trash.

  • 65 months ago
  • 1 point

Just to clarify: moving a virus to the trash won't necessarily undo the damage it did to your computer...

  • 65 months ago
  • 1 point

thats what it told me to do. i emptied it. its just a problem with safari what am i supposed to do

  • 65 months ago
  • 1 point

use a different browser? Maybe Chrome or Firefox

  • 65 months ago
  • 1 point

k

  • 65 months ago
  • 1 point

ClamX is not the greatest AV. Can you do a complete wipe of the drive?

  • 65 months ago
  • 1 point

no its my first mac i don't think i want to delete everything.

  • 65 months ago
  • 1 point

find a really good mac Anti virus if their is one. us windows users like me use AVG and MAlwarebytes which may have a version for mac i dont know

  • 64 months ago
  • 1 point

Try doing a boot scan, I'd reccomend Avast. It's pretty good.

  • 64 months ago
  • 1 point

i use avi antivirus found29 things

  • 64 months ago
  • 1 point

figure out what its called and unistall it using ccleaner

  • 64 months ago
  • 1 point

Check with a run by quickheal! Its affordable and heard it works fab with mac specially :)

  • 63 months ago
  • 1 point

AVG/quickheal both work fab actually! :)

  • 61 months ago
  • 1 point

Try using Sophos Antivirus for your mac PC.

[comment deleted by staff]
  • 64 months ago
  • 1 point

nah its good enough now

[comment deleted]
  • 64 months ago
  • 1 point

i got it fixed

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube