PCPartPicker

  • Log In
  • Register

Troubleshooting

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topics Start A New Topic

To aid in troubleshooting your issues, please include a permalink to your part list in your post (when applicable). Thanks!

Title Submitted By Replies Views Last Post
I think my motherboard burnt out after not even 3 months TexasGaming 13 87 2 hours ago by TexasGaming
Mouse lag, screen 2-4 sec freezes Tristenwalker5 2 4 3 hours ago by Tristenwalker5
Help With Understanding UFEI Bios winona78 0 6 4 hours ago by winona78
Printer Help Goodperson5656 8 30 5 hours ago by Goodperson5656
PROBLEMS WITH RUNNING MY PC FOR GAMES cheetozgodgalaxy 12 69 6 hours ago by cheetozgodgalaxy
Help with new Gpu setup BeatleJohn 4 23 7 hours ago by BeatleJohn
Pc won't boot up. kaotickronos 4 30 7 hours ago by kaotickronos
Cpu randomly died 1 hour after use and wont turn back on... asianoodleman 0 8 8 hours ago by asianoodleman
Vega 64 never reaching its boost clocks Frugert 1 18 10 hours ago by TexasGaming
Incorrect CPU Temp Readings winona78 7 40 14 hours ago by kschendel
Steam Files SpartyTech 18 77 15 hours ago by SpartyTech
Tried overclocking my EVGA 1660ti black Astastruerival28 3 34 16 hours ago by Astastruerival28
No Display and No Beeping at startup kinglouis123 3 30 20 hours ago by FancySnancy
Upgrade or not getting the performance I should? cheftony 1 20 1 day ago by kschendel
First Build: Startup Loop with no video feed BlouGreen 7 47 1 day ago by kschendel
Sony Vegas is being weird... again CatalystReaction 1 27 1 day ago by FancySnancy
Getting static/black screen when plugging into tv Leugi101 8 30 2 days ago by FancySnancy
First Build, pc seems to only want to boot the 2nd time i turn it on. BigMarst 7 40 2 days ago by Rin_Itoh
Help with M.2 slots and SATA ports FunkyFeber 1 25 2 days ago by LIVE_AMMO
I'm only getting the option for ethernet? Hey_Im_Nate 4 52 2 days ago by BetrayedPredator
Strange Intermittent Realtek Audio Problem in Windows 10 kageryu 5 40 2 days ago by kageryu
The weakest link? Jim44 8 50 2 days ago by legomaster
I am confused if this is bad for me? NARWHALS_3 3 52 3 days ago by Eltech
How to boot into windows? JoTheThot 1 43 3 days ago by FancySnancy
Need Help ProbablyProdigy 6 50 3 days ago by treloar
First Build-EZ debug VGA led-No signal to monitor hogfanx 12 69 3 days ago by Maple_Syrup
Either 100% fan usage or black screen on login after system upgrade TBinnington 0 17 3 days ago by TBinnington
JsUSB3, Is this properly connected? asianoodleman 2 42 3 days ago by asianoodleman
Is Ryzen still crashing Overwatch? twofewerfrags 5 25 3 days ago by twofewerfrags
computer GPU and CPU not performing to the max Kinesis. 16 99 3 days ago by treloar
Unclocking GPU for certain games. Underlying issue? Careramel 6 48 4 days ago by Rin_Itoh
Mic acting wierd Mircea-Alexandru 3 18 4 days ago by LIVE_AMMO
Mobile Website Gutterridgejake 1 74 5 days ago by ssjg5rlly
PC running really slow ziedonis 13 99 5 days ago by ziedonis
H60 running hot on r5 2600x Somedumbguy 13 49 5 days ago by G_rot777
First build, everything working fantastic, but receive "CPU fan error" on boot Bushmatic 4 44 5 days ago by Otterman366
Audio Issue msheridan77 3 44 6 days ago by msheridan77
Runs perfectly fine in windowed mode, stutters in fullscreen FancySnancy 9 46 6 days ago by treloar
HDD not working after new PSU winona78 12 44 6 days ago by treloar
Laptop dying even when on full battery or plugged in miggiesmalls24 0 9 6 days ago by miggiesmalls24
computer turns on, but does not boot dimm0k 3 43 6 days ago by pcbldragain
High Temps Azkii 7 43 6 days ago by FancySnancy
Second screen isn’t working JHow92 7 46 6 days ago by JHow92
Failed to Boot after cold boot. deakon24 0 16 7 days ago by deakon24
ASRock AB350 Pro4 Ryzen Build Boot Issue Stone710 12 114 7 days ago by Stone710
First Build: Boot Loop, No Video BlouGreen 0 13 7 days ago by BlouGreen
PC Crashing Again winona78 8 42 7 days ago by winona78
Computer freezing (almost all new hardware, still freezing) plutonium_239 2 33 8 days ago by plutonium_239
Windows isn't booting after replacing Motherboard Ruler596m 0 25 8 days ago by Ruler596m
Computer Will Not Boot DPRutledge 14 46 8 days ago by treloar
Page
1
·
·
·