Description

My new Updated build from fractal core 500 and i7 7700k to Ryzen 7 2700x, b450i and Cougar QBX case.

I've used the morpheus II cooler but i liked the design on this Artic Accelero III without the fans included setting bottom and rear fans to exhaust, Top , side and front fans are set to intake

Part Reviews

CPU

Well for an itx form it can turbo up to 4.1 with the noctua fans but it cant reach 4.3ghz on all cores but still decent buy with that cooler. Can play games, stream and watch movies at the same time

Thermal Compound

Decent old and reliable thermal paste

Thermal Compound

used with the artic accelero extreme III will help bring down temps to 5c to 10c

Motherboard

I think I like it much better than the Asus itx boards much more complete board even with 1 m.2 slot and cheaper

Memory

Expensive but with AM4 certified label you cant go wrong with this

Storage

Main Game drive to load faster to skip those tips on every game

Storage

3tb with 7200 rpm not bad the 4tb will only have 5900 rpm can't really see the difference

Video Card

Mini and fast good power delivery specially when you plug out the fans

Case

Tiny and compact no useless space

Power Supply

tiniest Fully modular psu that is ATX in size the seasonic m12 is like 150mm in length and will not fit with the cougar QBX the silverstone is 140mm in length and wil fit with no problem even in most ITX cases

Case Fan

nice 80mm fan

Case Fan

20mm fan 5mm slimmer than other 120mm fan

Monitor

75hz budget monitor with freesync!

Monitor

165hz is the best cant go back to 60hz now

Comments

  • 9 months ago
  • 1 point

I see that your cable management is as messy as mine! How do you find the noise in that case? I have a similar fan set-up to you and it is very noisy, especially when gaming. Doesn't bother me too much as I wear headphones. I'm also running an i5 8600k at 4.9 GHz so I definitely need all those fans.

  • 9 months ago
  • 1 point

it doesn't bother me too i had earphones and i have a huge fan to cool the inside of the room so its really not bad for me but for some other people it might drive them mad

  • 9 months ago
  • 1 point

How Mich did the GPU set you back?

  • 9 months ago
  • 1 point

to be honest i broke the fans of my gpu and made my warranty voided. it doesnt cool enough the gpu due to its size and case and i live in a tropical country so its really hot and humid here swapping gpu cooler with aftermarket cooler is much better. with a help of liquid metal it decreases the temp a little

  • 9 months ago
  • 1 point

stuff from overseas are expensive did pay more than 120 usd after converting it from php

  • 8 months ago
  • 1 point

i noticed you used an aftermarket gpu cooler, was it hard to fit into the case?

  • 7 months ago
  • 1 point

artic accelero extreme 3 bro its good oc my gpu to 2015mhz and memoery to 5800mhz i do also a raijintek morpheus 2 and its better to be honest its just it wont fit on my case it will fit more space for the fans cant externally mount the fans

  • 8 months ago
  • 1 point

Have you had any problems with the SSD? I've been thinking on getting it and it seems a little sketchy. 1TB for $100. Seems too good to be true.

  • 8 months ago
  • 1 point

The Team SSD.

  • 7 months ago
  • 1 point

its good dude its much faster than a hard drive thats what i can tell. ive been having problems with m.2 ssd it seem im buying bad m.2 ssd or they just get corrupted from time to time that's why my main os drive is a 2.5 inch drive

  • 1 month ago
  • 1 point

Are you using the stock cooler? what's the idle temp you got? I got the R5 2600 with the stock cooler, idle temp is 43~44 degrees. Paired with MSI Rx570. I'm from the Phils. so we have same ambient temperature and no AC unit in the room.

I was wondering how did you manage to install the 80mm fan in the front panel? I couldn't remove the QBX front panel. It almost broke when I tried to remove it.

Good job on the cable management. Mine is more messy than yours and I have the smaller PSU, Corsair SF450.

Mine is currently dead though. Don't know how to resolve this VGA debug led on so I can't get a POST after 5 months of usage. I was planning to post my build here after 8 or 9 months of usage.